TopographySurfaceIsBoundaryPoint Method

Identifies whether the given point is an existing boundary point of the current topography surface.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsBoundaryPoint(
	XYZ point
)

Parameters

point  XYZ
The point to be checked.

Return Value

Boolean
Returns true if a given point is an existing boundary point. For TopographySurface and SiteSubRegion elements, it returns false if the given point is an existing interior point of current topography surface. For the topography surface associated with a BuildingPad element, it always returns true if the point is a part of the element (all points are boundary points for the topography surface associated with a BuildingPad element).
Exceptions
ExceptionCondition
ArgumentException The input point does not exist in the current topography surface.
ArgumentNullException A non-optional argument was null
Remarks
This applies to TopographySurface, SiteSubRegion, and the topography surface associated with a BuildingPad element. The given point will be evaluated in XYZ. If a point matches the XY location, but not the elevation, an ArgumentException will be thrown if this point does not exist in current topography surface.
See Also