AreaLoadCreate(Document, ElementId, XYZ, AreaLoadType) Method |
Creates a new hosted area load within the project.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static AreaLoad Create(
Document document,
ElementId hostElemId,
XYZ forceVector,
AreaLoadType symbol
)
Public Shared Function Create (
document As Document,
hostElemId As ElementId,
forceVector As XYZ,
symbol As AreaLoadType
) As AreaLoad
public:
static AreaLoad^ Create(
Document^ document,
ElementId^ hostElemId,
XYZ^ forceVector,
AreaLoadType^ symbol
)
static member Create :
document : Document *
hostElemId : ElementId *
forceVector : XYZ *
symbol : AreaLoadType -> AreaLoad
Parameters
- document Document
-
Document to which new area load will be added.
- hostElemId ElementId
-
The analytical surface host element id for the area Load.
- forceVector XYZ
-
The force vector applied to the 1st reference point of the area load.
- symbol AreaLoadType
-
The symbol of the AreaLoad. Set to use default type.
Return Value
AreaLoad
If successful, returns an object of the newly created AreaLoad.
is returned if the operation fails.
ExceptionsException | Condition |
---|
ArgumentException |
The element hostElemId does not exist in the document
-or-
hostElemId is not permitted for this type of load.
-or-
Thrown when force vector is equal zero.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Thrown if type could not be set for newly created area load.
|
See Also