ConceptualConstructionTypeGetOpeningConstructionType Method |
Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetOpeningConstructionType(
Document ccda,
ConceptualConstructionOpeningType typeEnum
)
Public Shared Function GetOpeningConstructionType (
ccda As Document,
typeEnum As ConceptualConstructionOpeningType
) As ElementId
public:
static ElementId^ GetOpeningConstructionType(
Document^ ccda,
ConceptualConstructionOpeningType typeEnum
)
static member GetOpeningConstructionType :
ccda : Document *
typeEnum : ConceptualConstructionOpeningType -> ElementId
Parameters
- ccda Document
-
The Document.
- typeEnum ConceptualConstructionOpeningType
-
The ConceptualConstructionOpeningType to get the ConceptualConstructionType for.
Return Value
ElementId
Returns ElementId of a ConceptualConstructionType.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
The enum is invalid for ConceptualConstructionOpeningType.
-or-
A value passed for an enumeration argument is not a member of that enumeration
|
See Also