GlobalParametersManagerGetGlobalParametersOrdered Method |
Returns all global paramters in an ordered array.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> GetGlobalParametersOrdered(
Document document
)
Public Shared Function GetGlobalParametersOrdered (
document As Document
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetGlobalParametersOrdered(
Document^ document
)
static member GetGlobalParametersOrdered :
document : Document -> IList<ElementId>
Parameters
- document Document
-
Document containing the requested global parameters
Return Value
IListElementId
An array of Element Ids of all Global Parameters in the document.
ExceptionsException | Condition |
---|
ArgumentException |
Global parameters are not supported in the given document.
A possible cause is that it is not a project document,
for global parameters are not supported in Revit families.
|
ArgumentNullException |
A non-optional argument was null
|
RemarksThe order of the items coresponds to the order at which global parameters
appear in Revit UI when shown in the standard Global Parameters dialog.
However, the order of parameters is serialized in the document,
thus available on the DB level as well.
See Also