UnitsIsModifiableSpec Method |
Checks whether the default FormatOptions can be modified for a given spec.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsModifiableSpec(
ForgeTypeId specTypeId
)
Public Shared Function IsModifiableSpec (
specTypeId As ForgeTypeId
) As Boolean
public:
static bool IsModifiableSpec(
ForgeTypeId^ specTypeId
)
static member IsModifiableSpec :
specTypeId : ForgeTypeId -> bool
Parameters
- specTypeId ForgeTypeId
-
Identifier of the spec to check.
Return Value
Boolean
True if the FormatOptions can be modified, false otherwise.
Exceptions
Remarks
The Units class stores a FormatOptions object for every spec, but
not all of them can be directly modified. Some have fixed
definitions.
See Also