FilterGlobalParameterAssociationRule Constructor |
Constructs an instance of FilterGlobalParameterAssociationRule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FilterGlobalParameterAssociationRule(
FilterableValueProvider valueProvider,
FilterNumericRuleEvaluator evaluator,
ElementId ruleValue
)
Public Sub New (
valueProvider As FilterableValueProvider,
evaluator As FilterNumericRuleEvaluator,
ruleValue As ElementId
)
public:
FilterGlobalParameterAssociationRule(
FilterableValueProvider^ valueProvider,
FilterNumericRuleEvaluator^ evaluator,
ElementId^ ruleValue
)
new :
valueProvider : FilterableValueProvider *
evaluator : FilterNumericRuleEvaluator *
ruleValue : ElementId -> FilterGlobalParameterAssociationRule
Parameters
- valueProvider FilterableValueProvider
-
A pointer to a "value provider" object that will extract values from a Revit document.
- evaluator FilterNumericRuleEvaluator
-
A pointer to the filter rule evaluator object that implements the desired test.
The built-in evaluators implement commonly used tests such as less-than, greater-than
less-than-or-equal-to, equal, etc.
- ruleValue ElementId
-
The user-supplied global parameter value against which values from a Revit document will be tested.
Exceptions
See Also