RebarContainerItemGetCenterlineCurves(Boolean, Boolean, Boolean, MultiplanarOption) Method |
A chain of curves representing the centerline of the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Curve> GetCenterlineCurves(
bool adjustForSelfIntersection,
bool suppressHooks,
bool suppressBendRadius,
MultiplanarOption multiplanarOption
)
Public Function GetCenterlineCurves (
adjustForSelfIntersection As Boolean,
suppressHooks As Boolean,
suppressBendRadius As Boolean,
multiplanarOption As MultiplanarOption
) As IList(Of Curve)
public:
IList<Curve^>^ GetCenterlineCurves(
bool adjustForSelfIntersection,
bool suppressHooks,
bool suppressBendRadius,
MultiplanarOption multiplanarOption
)
member GetCenterlineCurves :
adjustForSelfIntersection : bool *
suppressHooks : bool *
suppressBendRadius : bool *
multiplanarOption : MultiplanarOption -> IList<Curve>
Parameters
- adjustForSelfIntersection Boolean
-
If the curves overlap, as in a planar stirrup, this parameter controls
whether they should be adjusted to avoid intersection (as in fine views),
or kept in a single plane for simplicity (as in coarse views).
- suppressHooks Boolean
-
Identifies if the chain will include hooks curves.
- suppressBendRadius Boolean
-
Identifies if the connected chain will include unfilleted curves.
- multiplanarOption MultiplanarOption
-
If the Rebar is a multi-planar shape, this parameter controls whether to generate only
the curves in the primary plane (IncludeOnlyPlanarCurves), or to generate all curves,
(IncludeAllMultiplanarCurves) including the out-of-plane connector segments as well as
multi-planar copies of the primary plane curves.
This argument is ignored for planar shapes.
Return Value
IListCurve
The centerline curves or empty array if the curves cannot be computed because
the parameters values are inconsistent
with the constraints of the RebarShape definition.
Exceptions
Remarks
If the Rebar is a set, meaning GetLayoutRule() does not return Single,
this method returns the first rebar in the set, even if the
first bar is suppressed by IncludeFirstBar being false.
See Also