RebarContainerItemSetFromRebar Method |
Set an instance of a RebarContainerItem element according to a Rebar parameters.
Will throw exception if given rebar is not shape driven.
Will throw exception if given rebar has moved bars in set.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetFromRebar(
Rebar rebar
)
Public Sub SetFromRebar (
rebar As Rebar
)
public:
void SetFromRebar(
Rebar^ rebar
)
member SetFromRebar :
rebar : Rebar -> unit
Parameters
- rebar Rebar
-
The Rebar.
ExceptionsException | Condition |
---|
ArgumentException |
The RebarShape of rebar has End Treatments
-or-
Can't create container from free-form rebar.
-or-
Can't create container from Rebar with moved bars.
-or-
Can't create container from Rebar which has excluded bars other than the first and last one.
|
ArgumentNullException |
A non-optional argument was null
|
See Also