RouteAnalysisSettingsSetIgnoredCategoryIds Method |
Sets the ElementIds for Category elements which are ignored by route calculation.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetIgnoredCategoryIds(
ICollection<ElementId> categoryIds
)
Public Sub SetIgnoredCategoryIds (
categoryIds As ICollection(Of ElementId)
)
public:
void SetIgnoredCategoryIds(
ICollection<ElementId^>^ categoryIds
)
member SetIgnoredCategoryIds :
categoryIds : ICollection<ElementId> -> unit
Parameters
- categoryIds ICollectionElementId
-
The ids of Categories to be ignored by route calculation.
Exceptions
See Also