AnalyticalElementStructuralRole Property

The enum value depicting structural role asigned to the Analytical Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public AnalyticalStructuralRole StructuralRole { get; set; }

Property Value

AnalyticalStructuralRole
Exceptions
ExceptionCondition
ArgumentException When setting this property: The provided AnalyticalStructuralRole is not supported
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also