AnalyticalStructuralRole Enumeration |
Indicates the structural role for the analytical elements.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum AnalyticalStructuralRole
Public Enumeration AnalyticalStructuralRole
public enum class AnalyticalStructuralRole
type AnalyticalStructuralRole
MembersMember name | Value | Description |
---|
StructuralRoleBeam | 0 |
Member plays role of structural beam.
|
StructuralRoleColumn | 1 |
Member plays role of structural column.
|
StructuralRoleMember | 3 |
Member plays role of structural member.
|
StructuralRoleGirder | 4 |
Member plays role of structural girder.
|
StructuralRoleFloor | 5 |
Member plays role of structural floor.
|
StructuralRoleWall | 6 |
Member plays role of structural wall.
|
StructuralRolePanel | 7 |
Member plays role of structural panel.
|
Unset | -1 |
No structural role by default.
|
See Also