FailuresAccessorCommitPendingTransaction Method

Finishes pending failures processing by committing the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public TransactionStatus CommitPendingTransaction()

Return Value

TransactionStatus
Result of attempt to commit the pending transaction.
Exceptions
ExceptionCondition
InvalidOperationException This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state. -or- There is no pending transaction or transaction is not allowed to be committed.
See Also