ViewSheetGetAllRevisionIds Method |
Gets the ordered array of Revisions which participate in the sheet's revision schedules.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<ElementId> GetAllRevisionIds()
Public Function GetAllRevisionIds As IList(Of ElementId)
public:
IList<ElementId^>^ GetAllRevisionIds()
member GetAllRevisionIds : unit -> IList<ElementId>
Return Value
IListElementId
The ordered array of ids of Revisions participating in the sheet's revision schedules.
Remarks
The Revisions are ordered according to the revision sequence in the project.
A Revision is considered to be participating in revision scheduling on the sheet
if either a revision cloud belonging to that Revision is visible on the sheet or the Revision
has been explicitly included using the Revisions On Sheet parameter.
See Also