VisibleInViewFilter(Document, ElementId) Constructor |
Constructs a new instance of a VisibleInViewFilter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic VisibleInViewFilter(
Document document,
ElementId viewId
)
Public Sub New (
document As Document,
viewId As ElementId
)
public:
VisibleInViewFilter(
Document^ document,
ElementId^ viewId
)
new :
document : Document *
viewId : ElementId -> VisibleInViewFilter
Parameters
- document Document
-
The document that owns the view.
- viewId ElementId
-
The view id.
ExceptionsException | Condition |
---|
ArgumentException |
viewId is not a view.
-or-
viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates
will fail this check.
|
ArgumentNullException |
A non-optional argument was null
|
See Also