LinePatternElementGetSolidPatternId Method |
Gets the solid line pattern element id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetSolidPatternId()
Public Shared Function GetSolidPatternId As ElementId
public:
static ElementId^ GetSolidPatternId()
static member GetSolidPatternId : unit -> ElementId
Return Value
ElementId
The element id of the solid line pattern.
Remarks
Note that Solid is special. It isn't a line pattern at all -- it is a special code that tells drawing
and export code to use solid lines rather than patterned lines. Solid is visible to the user when selecting
line patterns.
See Also