RouteAnalysisSettingsGetIgnoredCategoryIds Method |
Returns ElementIds for Category elements which are ignored (not taken into account) route calculation.
To enable ignoring of these categories,
EnableIgnoredCategoryIds must be set to true.
If an ignored category has sub-categories, then the sub-categories will be ignored as well.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetIgnoredCategoryIds()
Public Function GetIgnoredCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetIgnoredCategoryIds()
member GetIgnoredCategoryIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
The ids of Categories which are ignored by route calculation. By default, the set contains the Doors Category.
See Also