ExternalFileUtilsIsExternalFileReference Method |
Determines whether the given element represents an external file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsExternalFileReference(
Document aDoc,
ElementId elemId
)
Public Shared Function IsExternalFileReference (
aDoc As Document,
elemId As ElementId
) As Boolean
public:
static bool IsExternalFileReference(
Document^ aDoc,
ElementId^ elemId
)
static member IsExternalFileReference :
aDoc : Document *
elemId : ElementId -> bool
Parameters
- aDoc Document
-
A Revit Document.
- elemId ElementId
-
The element to be checked for an external file reference.
Return Value
Boolean
True if the given element represents an external file; false otherwise.
Exceptions
RemarksCAD imports are not external file references, as their
data is brought fully into Revit. No connection is maintained
to the original file.
A link may be an external resource without being an external file.
See Also