SubelementGetValidTypes Method |
Obtains a set of types that are valid for this subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElementId> GetValidTypes()
Public Function GetValidTypes As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetValidTypes()
member GetValidTypes : unit -> ISet<ElementId>
Return Value
ISetElementId
A set of element IDs of types that are valid for this subelement or an empty set if subelement cannot have type assigned.
Remarks
A type is valid for a subelement if it can be assigned to the subelement.
See Also