ConceptualConstructionTypeGetWallConstructionType Method |
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ElementId GetWallConstructionType(
Document ccda,
ConceptualConstructionWallType typeEnum
)
Public Shared Function GetWallConstructionType (
ccda As Document,
typeEnum As ConceptualConstructionWallType
) As ElementId
public:
static ElementId^ GetWallConstructionType(
Document^ ccda,
ConceptualConstructionWallType typeEnum
)
static member GetWallConstructionType :
ccda : Document *
typeEnum : ConceptualConstructionWallType -> ElementId
Parameters
- ccda Document
-
The Document.
- typeEnum ConceptualConstructionWallType
-
The ConceptualConstructionWallType to get the ConceptualConstructionType for.
Return Value
ElementId
Returns ElementId of a ConceptualConstructionType.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was null
|
ArgumentOutOfRangeException |
The enum is invalid for ConceptualConstructionWallType.
-or-
A value passed for an enumeration argument is not a member of that enumeration
|
See Also