ExporterIFCGet3DContextHandle Method |
Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IFCAnyHandle Get3DContextHandle(
string subContextName
)
Public Function Get3DContextHandle (
subContextName As String
) As IFCAnyHandle
public:
IFCAnyHandle^ Get3DContextHandle(
String^ subContextName
)
member Get3DContextHandle :
subContextName : string -> IFCAnyHandle
Parameters
- subContextName String
-
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.
Return Value
IFCAnyHandle
The IfcRepresentationContext for 3D entities.
Exceptions
Remarks
The context handle automatically incorporates the angle to true north for the document.
See Also