DisplacementElementSetDisplacedElementIds Method |
Sets the ids of the elements affected by this DisplacementElement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetDisplacedElementIds(
ICollection<ElementId> displacedElemIds
)
Public Sub SetDisplacedElementIds (
displacedElemIds As ICollection(Of ElementId)
)
public:
void SetDisplacedElementIds(
ICollection<ElementId^>^ displacedElemIds
)
member SetDisplacedElementIds :
displacedElemIds : ICollection<ElementId> -> unit
Parameters
- displacedElemIds ICollectionElementId
-
Set of ids of elements to be displaced by this DisplacementElement.
ExceptionsException | Condition |
---|
ArgumentException |
For each individual element in the set displacedElemIds, isAllowedAsDisplacedElement must return true, and the
elements must not already be displaced in the specified view.
|
ArgumentNullException |
A non-optional argument was null
|
See Also