IExportContext2DOnElementBegin2D Method

This method marks the beginning of an element to be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
RenderNodeAction OnElementBegin2D(
	ElementNode node
)

Parameters

node  ElementNode
Node representing the element that is about to start being exported. Contains element ID and document.

Return Value

RenderNodeAction
Return RenderNodeAction.Skip if you wish to skip exporting this element, or return RenderNodeAction.Proceed otherwise.
Remarks
For views having non-Wireframe display style, geometry of elements is output outside of view, instance and link begin/end brackets. Therefore the argument to this method is ElementNode that has both element ID and the host document.
See Also