SystemZoneData Class

Represents the specific domain requirements for a system-zone used in MEP design.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.AnalysisGenericZoneDomainData
    Autodesk.Revit.DB.MechanicalSystemZoneData

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SystemZoneData : GenericZoneDomainData

The SystemZoneData type exposes the following members.

Properties
 NameDescription
Public propertyZoneEquipmentId The id of the zone equipment related to the zone.
Top
Methods
 NameDescription
Public methodStatic memberCreate Creates a new instance of a system-zone data domain class.
Top
Remarks
A system-zone is used to specify what parts of a building are served by specific equipment, air systems and water loops without having to physically model them. A system-zone is represented as a GenericZone element with a domain data of type SystemZoneData, which contains specific domain requirements for the purpose of analysis.
See Also