SplitButtonCurrentButton Property

Gets or sets the current PushButton of the SplitButton.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public PushButton CurrentButton { get; set; }

Property Value

PushButton
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when trying to set the CurrentButton to .
ArgumentExceptionThrown when trying to set the CurrentButton to a button which is not in current drop-down list.
InvalidOperationExceptionThrown when trying to set the CurrentButton if IsSynchronizedWithCurrentItem is false.
Remarks
This property is applicable only if IsSynchronizedWithCurrentItem is true. The default value of this property will be the first enabled PushButton in the drop down list after the SplitButton is shown.
See Also