CurveUVAs3DCurveInXYPlane Method |
Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Curve As3DCurveInXYPlane()
Public Function As3DCurveInXYPlane As Curve
public:
Curve^ As3DCurveInXYPlane()
member As3DCurveInXYPlane : unit -> Curve
Return Value
Curve
3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Remarks
Ideally, this function should only be used in cases when the 2D curve needs to be used in a context
that does not support 2D curves, but can represent them as 3D curves with Z = 0 everywhere (for example,
converting the 2D curve to another CAD system that does not support 2D curves).
See Also