FailureMessageSetFailingElements Method |
Sets elements that have caused the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FailureMessage SetFailingElements(
ICollection<ElementId> idsToShow
)
Public Function SetFailingElements (
idsToShow As ICollection(Of ElementId)
) As FailureMessage
public:
FailureMessage^ SetFailingElements(
ICollection<ElementId^>^ idsToShow
)
member SetFailingElements :
idsToShow : ICollection<ElementId> -> FailureMessage
Parameters
- idsToShow ICollectionElementId
-
The elements that have caused the failure.
Return Value
FailureMessage
The FailureMessage.
Exceptions
Remarks
In the Revit error dialog these elements will be highlighted to the user and can be deleted by user via extended error dialog.
See Also