RebarShapeConstraintSegmentLength Constructor |
Create a segment length constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic RebarShapeConstraintSegmentLength(
ElementId paramId,
RebarShapeSegmentEndReferenceType refType0,
RebarShapeSegmentEndReferenceType refType1
)
Public Sub New (
paramId As ElementId,
refType0 As RebarShapeSegmentEndReferenceType,
refType1 As RebarShapeSegmentEndReferenceType
)
public:
RebarShapeConstraintSegmentLength(
ElementId^ paramId,
RebarShapeSegmentEndReferenceType refType0,
RebarShapeSegmentEndReferenceType refType1
)
new :
paramId : ElementId *
refType0 : RebarShapeSegmentEndReferenceType *
refType1 : RebarShapeSegmentEndReferenceType -> RebarShapeConstraintSegmentLength
Parameters
- paramId ElementId
-
The Id of a Rebar Shape parameter.
- refType0 RebarShapeSegmentEndReferenceType
-
Choose between two possibilities for the first reference of the length constraint.
- refType1 RebarShapeSegmentEndReferenceType
-
Choose between two possibilities for the second reference of the length constraint.
Exceptions
See Also