StartingViewSettingsViewId Property |
Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates
that no view has been specified. In that case, Revit will open the last views that were open at the
time the file was saved.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId ViewId { get; set; }
Public Property ViewId As ElementId
Get
Set
public:
property ElementId^ ViewId {
ElementId^ get ();
void set (ElementId^ value);
}
member ViewId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: viewId is not an acceptable starting view for this model.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
Note that InvalidElementId will cause Revit to open the same view it would have used
in Revit 2011 and prior releases.
See Also