Generic Class

A static class that provides access to the property names that appear in the Generic visual asset schema.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.VisualGeneric

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Generic

The Generic type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberColorByObject The property labeled "Color By Object" from the "Generic" schema.
Public propertyStatic memberCommonTintColor The property labeled "Tint Color" from the "Generic" schema.
Public propertyStatic memberCommonTintToggle The property labeled "Tint" from the "Generic" schema.
Public propertyStatic memberGenericBumpAmount The property labeled "Amount" from the "Generic" schema.
Public propertyStatic memberGenericBumpMap The property labeled "Bump" from the "Generic" schema.
Public propertyStatic memberGenericCutoutOpacity The property labeled "Cutouts" from the "Generic" schema.
Public propertyStatic memberGenericDiffuse The property labeled "Color/Image" from the "Generic" schema.
Public propertyStatic memberGenericDiffuseImageFade The property labeled "Image Fade" from the "Generic" schema.
Public propertyStatic memberGenericGlossiness The property labeled "Glossiness" from the "Generic" schema.
Public propertyStatic memberGenericIsMetal The property labeled "Highlights" from the "Generic" schema.
Public propertyStatic memberGenericReflectivityAt0deg The property labeled "Reflectivity/Direct" from the "Generic" schema.
Public propertyStatic memberGenericReflectivityAt90deg The property labeled "Reflectivity/Oblique" from the "Generic" schema.
Public propertyStatic memberGenericRefractionIndex The property labeled "Refraction" from the "Generic" schema.
Public propertyStatic memberGenericRefractionTranslucencyWeight The property labeled "Translucency" from the "Generic" schema.
Public propertyStatic memberGenericSelfIllumColorTemperature The property labeled "Color Temperature" from the "Generic" schema.
Public propertyStatic memberGenericSelfIllumFilterMap The property labeled "Filter Color" from the "Generic" schema.
Public propertyStatic memberGenericSelfIllumLuminance The property labeled "Luminance" from the "Generic" schema.
Public propertyStatic memberGenericTransparency The property labeled "Transparency" from the "Generic" schema.
Public propertyStatic memberGenericTransparencyImageFade The property labeled "Image Fade" from the "Generic" schema.
Top
See Also