ViewSheetGetAllRevisionCloudIds Method |
Gets the ids of the revision clouds which appear on the sheet's revision schedules.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElementId> GetAllRevisionCloudIds()
Public Function GetAllRevisionCloudIds As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAllRevisionCloudIds()
member GetAllRevisionCloudIds : unit -> ISet<ElementId>
Return Value
ISetElementId
The ids of the revisions clouds which appear on the sheet's revision schedules.
Remarks
The sheet's revision schedules include the revisions that are associated with revision clouds that are visible on the sheet.
Revision schedules may also include revisions that have been additionally added to the sheet via the Revisions On Sheets parameter.
Use
GetAdditionalRevisionIds to get the additionally added revisions.
See Also