ProjectLocationIsProjectLocationNameUnique Method |
Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsProjectLocationNameUnique(
Document document,
string name,
ElementId siteLocationId
)
Public Shared Function IsProjectLocationNameUnique (
document As Document,
name As String,
siteLocationId As ElementId
) As Boolean
public:
static bool IsProjectLocationNameUnique(
Document^ document,
String^ name,
ElementId^ siteLocationId
)
static member IsProjectLocationNameUnique :
document : Document *
name : string *
siteLocationId : ElementId -> bool
Parameters
- document Document
-
The document to check.
- name String
-
The name to check.
- siteLocationId ElementId
-
The ElementId of the SiteLocation which the ProjectLocation belongs to.
Return Value
Boolean
True if the name is unused (among ProjectLocations). False otherwise.
Exceptions
See Also