CurveLoopGetRectangularWidth Method |
Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetRectangularWidth(
Plane plane
)
Public Function GetRectangularWidth (
plane As Plane
) As Double
public:
double GetRectangularWidth(
Plane^ plane
)
member GetRectangularWidth :
plane : Plane -> float
Parameters
- plane Plane
-
The plane to which the curves will be projected.
Return Value
Double
The width.
Exceptions
Remarks
The width is determined by the U extents of the UV curve created by from the curve loop plane.
See Also