DocumentNewSlabEdge(SlabEdgeType, Reference) Method |
Creates a slab edge along a reference.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SlabEdge NewSlabEdge(
SlabEdgeType SlabEdgeType,
Reference reference
)
Public Function NewSlabEdge (
SlabEdgeType As SlabEdgeType,
reference As Reference
) As SlabEdge
public:
SlabEdge^ NewSlabEdge(
SlabEdgeType^ SlabEdgeType,
Reference^ reference
)
member NewSlabEdge :
SlabEdgeType : SlabEdgeType *
reference : Reference -> SlabEdge
Parameters
- SlabEdgeType SlabEdgeType
- The type of the slab edge to create
- reference Reference
- A planar line or arc that represents the place where you
want to place the slab edge.
Return Value
SlabEdge If successful a new slab edge object within the project, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the slab edge type does not exist in the given document. |
See Also