PointRelativeToPoint Class

Represents a point placed relative to another point.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBPointElementReference
    Autodesk.Revit.DBPointRelativeToPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointRelativeToPoint : PointElementReference

The PointRelativeToPoint type exposes the following members.

Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetHostPointReferenceGet a copy of the host point reference.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetHostPointReferenceChange the host point reference.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
For this release, the only workflow supported is that the point is placed coincident with the referenced host (a relative transformation of Transform.Identity).
See Also