ElementIntersectsElementFilter(Element, Boolean) Constructor |
Constructs a filter to match elements which intersect the given element, with the
option to match all elements not intersecting the given element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementIntersectsElementFilter(
Element element,
bool inverted
)
Public Sub New (
element As Element,
inverted As Boolean
)
public:
ElementIntersectsElementFilter(
Element^ element,
bool inverted
)
new :
element : Element *
inverted : bool -> ElementIntersectsElementFilter
Parameters
- element Element
-
The element to check for intersection.
- inverted Boolean
-
True if the filter should match all elements which do not intersect the given
element.
ExceptionsException | Condition |
---|
ArgumentException |
The category of the element is not supported for element intersection filters.
-or-
The element is not supported for element intersection filters.
|
ArgumentNullException |
A non-optional argument was null
|
See Also