UIDocumentCanPlaceElementType Method |
Verifies that the user can be prompted to place the input element type interactively.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanPlaceElementType(
ElementType elementType
)
Public Function CanPlaceElementType (
elementType As ElementType
) As Boolean
public:
bool CanPlaceElementType(
ElementType^ elementType
)
member CanPlaceElementType :
elementType : ElementType -> bool
Parameters
- elementType ElementType
-
The ElementType.
Return Value
Boolean
True if the user can be prompted to place the input element type interactively, false otherwise.
Exceptions
Remarks
If an element type can be placed interactively, it may be used as input to
PostRequestForElementTypePlacement(ElementType)
to have the user place an instance of the element. However, this function does not evaluate whether that element instance may
actually be placed in the current active view.
See Also