PartMakerMethodToDivideVolumesAddIntersectingReference Method |
Adds intersecting reference with an offset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AddIntersectingReference(
ElementId intersectingReference,
double offset
)
Public Function AddIntersectingReference (
intersectingReference As ElementId,
offset As Double
) As Boolean
public:
bool AddIntersectingReference(
ElementId^ intersectingReference,
double offset
)
member AddIntersectingReference :
intersectingReference : ElementId *
offset : float -> bool
Parameters
- intersectingReference ElementId
-
Id of the new intersecting reference.
- offset Double
-
The Offste for the new intersecting reference.
Return Value
Boolean
True if the PartMaker did not already use this
intersecting reference and it was added, false if the PartMaker
already used this intersecting reference and this call
only updated its offset.
ExceptionsException | Condition |
---|
ArgumentException |
The element id was not permitted as intersecting references.
Intersecting references should be levels, grids, or reference planes.
|
ArgumentNullException |
A non-optional argument was null
|
See Also