FieldBuilderSetSpec Method

Sets the spec describing the field's values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FieldBuilder SetSpec(
	ForgeTypeId specTypeId
)

Parameters

specTypeId  ForgeTypeId
Identifier of the spec.

Return Value

FieldBuilder
The FieldBuilder object may be used to add more details to the field.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
InvalidOperationException The SchemaBuilder has already finished building the Schema. -or- The field type does not utilize unit conversions.
See Also