SaveAsOptionsPreviewViewId Property |
The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId PreviewViewId { get; set; }
Public Property PreviewViewId As ElementId
Get
Set
public:
property ElementId^ PreviewViewId {
ElementId^ get ();
void set (ElementId^ value);
}
member PreviewViewId : ElementId with get, set
Property Value
ElementId
The id must be valid for use as a preview view (check DocumentPreviewSettings.IsValidPreviewViewId()).
Revit does not check validity when setting this value, only when the options are used in a call to SaveAs().
Default is InvalidElementId.
Exceptions
Remarks
If this id is set to a view id, the indicated view will be used to generate the preview even if
DocumentPreviewSettings.PreviewViewId is also set.
See Also