CompoundStructureGetSegmentCoordinate Method |
Gets the coordinate of a segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double GetSegmentCoordinate(
int segmentId
)
Public Function GetSegmentCoordinate (
segmentId As Integer
) As Double
public:
double GetSegmentCoordinate(
int segmentId
)
member GetSegmentCoordinate :
segmentId : int -> float
Parameters
- segmentId Int32
-
The id of a segment in this CompoundStructure.
Return Value
Double
The local coordinates of the specified segment.
Exceptions
Remarks
The boundaries of the regions of a vertically compound structure consist of vertical
horizontal segments.
If the segment orientation is horizontal, then its coordinate will lie in the range [0.0, SampleHeight].
If the segment orientation is vertical, then its coordinate will lie in the range of u values obtained from
GetRegionEnvelope(Int32).
See Also