CompoundStructureGetRegionEnvelope Method |
Gets the envelope that a specified region spans.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxUV GetRegionEnvelope(
int regionId
)
Public Function GetRegionEnvelope (
regionId As Integer
) As BoundingBoxUV
public:
BoundingBoxUV^ GetRegionEnvelope(
int regionId
)
member GetRegionEnvelope :
regionId : int -> BoundingBoxUV
Parameters
- regionId Int32
-
The id of the region.
Return Value
BoundingBoxUV
The envelope of the region.
Exceptions
Remarks
This envelope indicates the external boundary of the region. The
coordinate system it defines is used in the results of GetSegmentCoordinate().
See Also