FailuresAccessorIsElementsDeletionPermitted(IListElementId) Method |
Checks if resolution of the failures by deleting given collection of elements is permitted.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsElementsDeletionPermitted(
IList<ElementId> idsToDelete
)
Public Function IsElementsDeletionPermitted (
idsToDelete As IList(Of ElementId)
) As Boolean
public:
bool IsElementsDeletionPermitted(
IList<ElementId^>^ idsToDelete
)
member IsElementsDeletionPermitted :
idsToDelete : IList<ElementId> -> bool
Parameters
- idsToDelete IListElementId
-
The Ids of elements to be deleted.
Return Value
Boolean
True if resolution of the failures by deleting given elements is permitted.
Exceptions
Remarks
Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies
that given elements exist and can be deleted in the current state of the document.
See Also