CurveByPointsUtilsAddCurvesToFaceRegion Method |
Adds The CurveElements to one or more FaceRegions.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void AddCurvesToFaceRegion(
Document document,
IList<ElementId> curveElemIds
)
Public Shared Sub AddCurvesToFaceRegion (
document As Document,
curveElemIds As IList(Of ElementId)
)
public:
static void AddCurvesToFaceRegion(
Document^ document,
IList<ElementId^>^ curveElemIds
)
static member AddCurvesToFaceRegion :
document : Document *
curveElemIds : IList<ElementId> -> unit
Parameters
- document Document
-
The Document.
- curveElemIds IListElementId
-
The ElementIds of CurveElements which are to define the FaceRegion.
ExceptionsException | Condition |
---|
ArgumentException |
All the input CurveElements must be CurveByPoints, with the sketchOnSurface attribute set to True, and for each CurveElement, the defining
ReferencePoints must be hosted on References related to a common Face or Edge.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
Failed to add curves to FaceRegion.
|
Remarks
The CurveElements that are input may produce an arbitrary number of regions.
See Also