WallFoundationCreate Method |
Creates a new wall foundation within the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static WallFoundation Create(
Document document,
ElementId typeId,
ElementId wallId
)
Public Shared Function Create (
document As Document,
typeId As ElementId,
wallId As ElementId
) As WallFoundation
public:
static WallFoundation^ Create(
Document^ document,
ElementId^ typeId,
ElementId^ wallId
)
static member Create :
document : Document *
typeId : ElementId *
wallId : ElementId -> WallFoundation
Parameters
- document Document
-
The document.
- typeId ElementId
-
The id of the wall foundation type of the newly created wall foundation.
- wallId ElementId
-
The id of the host wall of the newly created wall foundation.
Return Value
WallFoundation
If successful, returns the newly created wall foundation,
otherwise.
Exceptions
See Also