DocumentNewFlexPipe(Connector, Connector, FlexPipeType) Method

Adds a new flexible pipe into the document, using two connector, and flexible pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FlexPipe NewFlexPipe(
	Connector connector1,
	Connector connector2,
	FlexPipeType pipeType
)

Parameters

connector1  Connector
The first connector to be connected to the pipe.
connector2  Connector
The second connector to be connected to the pipe.
pipeType  FlexPipeType
The type of the flexible pipe.

Return Value

FlexPipe
If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument connector1 or connector2 is .
InvalidOperationException Thrown when the flexible pipe cannot be created or regenerate fails.
ArgumentExceptionThrown if the flexible pipe type does not exist in the given document.
Remarks
If the connectors are fitting or equipment connectors of the correct domain, and if the connectors' direction match the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.
See Also