WallCreate(Document, IListCurve, Boolean) Method |
Creates a non rectangular profile wall within the project using the default wall type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Wall Create(
Document document,
IList<Curve> profile,
bool structural
)
Public Shared Function Create (
document As Document,
profile As IList(Of Curve),
structural As Boolean
) As Wall
public:
static Wall^ Create(
Document^ document,
IList<Curve^>^ profile,
bool structural
)
static member Create :
document : Document *
profile : IList<Curve> *
structural : bool -> Wall
Parameters
- document Document
-
The document in which the new wall is created.
- profile IListCurve
-
An array of planar curves that represent the vertical profile of the wall.
- structural Boolean
-
If set, specifies that the wall is structural in nature.
Return Value
Wall
If successful a new wall object within the project.
Exceptions
See Also