RibbonItemEventArgs Class

The base class of the RibbonItem event arguments which have UIApplication property.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RibbonItemEventArgs : EventArgs

The RibbonItemEventArgs type exposes the following members.

Constructors
 NameDescription
Public methodRibbonItemEventArgsInitializes a new instance of the RibbonItemEventArgs class
Top
Properties
 NameDescription
Public propertyApplication The current UIApplication.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also