StairsTypeMiddleSupportsNumber Property

The number of middle supports used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int MiddleSupportsNumber { get; set; }

Property Value

Int32
0 if the stairs type has no middle support.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: The given value for supportsNumber is negative.
InvalidOperationException When setting this property: The stairs type has no middle support so the data being set is not applicable.
See Also