RouteAnalysisSettingsGetExcludedCategoryIds Method |
Returns ElementIds for Category elements which are excluded (not taken into account) by route calculation.
These categories are always excluded, regardless of the
EnableIgnoredCategoryIds value.
If an excluded category has sub-categories, then the sub-categories will be excluded as well.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetExcludedCategoryIds()
Public Function GetExcludedCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetExcludedCategoryIds()
member GetExcludedCategoryIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
The ids of Categories which are excluded by route calculation.
See Also