UpdaterDataGetDeletedElementIds Method |
Returns set of elements that were deleted from the document.
This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetDeletedElementIds()
Public Function GetDeletedElementIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetDeletedElementIds()
member GetDeletedElementIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
Set of elements that were deleted from the document and triggered the call to execute()
Note: This will only return elements if the trigger registered for the associated updater
contains the ChangeType returned by Element::getChangeTypeElementDeletion()
See Also